Clojure

Clojure 中文群

u-d 4 days ago
还有react-swipeable-views
u-faadagjchb 4 days ago
你说package.json里面吗
u-faadagjchb 4 days ago
感觉应该不是这个的问题
u-d 4 days ago
我试了很多方法,都有依赖问题。
u-faadagjchb 4 days ago
你看我的版本
u-faadagjchb 4 days ago
我这里单用这个是没有问题的。如果你需要清理构建缓存的话,可以把项目里的 .shadow-cljs 删了
u-faadagjchb 4 days ago
shadow-cljs 引npm包的机制,和webpack基本上是一样的。
u-d 4 days ago
还有react-swipeable-views你可以顺手试下,我和Steven Chen都有问题。
u-faadagjchb 4 days ago
yarn add v1.19.1 warning package.json: No license field warning No license field [1/4] Resolving packages... warning react-swipeable-views > react-swipeable-views-utils > fbjs > core-js@1.2.7: core-js@<3.0 is no longer maintained and not recommended for usage due to the number of issues. Please, upgrade your dependencies to the actual version of core-js@3.
u-faadagjchb 4 days ago
这两包的 core-js 依赖不同啊
u-faadagjchb 4 days ago
这两你可能没发一起用。
u-jia 4 days ago
想请教下,我在login.cljs引入了这个log之后,lein figwheel之后编译就报错了。
u-jgfgcedgfbeheiff 4 days ago
有语法错误@养乐多
u-jgfgcedgfbeheiff 4 days ago
encore.cljs有语法错误
u-faadagjchb 4 days ago
打开那个文件看一眼?
u-jia 4 days ago
我看一下
u-jia 4 days ago
是不是命名空间有问题?
u-jia 4 days ago
噢噢,不是,看错了
u-jia 4 days ago
[Unsupported msg]
u-faadagjchb 4 days ago
看起来像某个库把这个文件用edn的格式读了?
u-faadagjchb 4 days ago
好奇怪,我用edn/read-string读了下好像没啥问题。
u-jia 4 days ago
我在这个文件夹也没找到edn.clj
u-faadagjchb 4 days ago
那个是clojure.tools.reader.edn
u-faadagjchb 4 days ago
考虑显式的指定一个timbre的版本?
u-jia 4 days ago
在project.clj指定了
u-faadagjchb 4 days ago
把encore的版本也定下来呢?
u-jia 4 days ago
我换成92的试试。
u-jia 4 days ago
还是会报,刚lein figwheel的时候发现有提示target目录没clean成功。
u-faadagjchb 4 days ago
目录权限?
u-jia 4 days ago
可能刚刚有文件被占用了,我重新试一下
u-jia 4 days ago
我关闭了所有文件都无法clean
u-faadagjchb 4 days ago
你看他给了你一个配置的提示
u-jia 4 days ago
我再试试,有问题再请教一下各位啦
u-facfabjjhaccccddfihfj 4 days ago
chat img
u-aagcji 4 days ago
这是啥
u-facafichciiiheihbb 4 days ago
cps/callcc?